Amazon Plugin Ported to WP 1.5

I’ve updated the Amazon plugin to work with WordPress 1.5. The plugin uses a class called “Snoopy” to connect to Amazon, and this, it turns out, as been added as a class in the core WordPress code. So when I redefined it in my plugin, it was causing a problem with the Dashboard, which was trying to reinclude the class. The fix (thanks to George for beating me to the punch on diagnosing the problem and sending in a fix) can be downloaded here. The changes included deleting the Snoopy class definition and requiring snoopy-class.php from wp-includes.

16 thoughts on “Amazon Plugin Ported to WP 1.5

  1. David James Pettifor says:

    I cannot for the life of me get this plugin working. Text appears below my categories list saing Amazon wsh list but nothing else. What do i need to do in order to get an image of a book from my wishlist to appear? Maybe i have not entered my wishlist id correctly. It is currently entered as numbers in the following format xxx-xxxxxxx-xxxxxxx. Any help most appreciated.

  2. Hey guys, working on installing the plug-in, with a little tweaking I seem to have gotten it working, aside from teh fact that it doesn’t like my wishlist id. My main question is, how do you format the output of the amazon side-bar section? I noticed it’s formatted on here, but if you take a look at my website you’ll see that it’s all in bold lettering, and of course i don’t program in PHP…. Any thoughts?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s